Supported Plugins

Last updated: 2018-09-30 15:13:19

PDF

TencentDB for PostgreSQL supports creating custom plugins (create extension pluginName). The following plugins are supported (some plugins are no longer supported in PostgreSQL 10 due to its more powerful features):

  • fdw plugin (not supported in pg 10)
  • postgis
  • pl/pgsql
  • pl/tcl
  • pl/perl
  • hstore
  • postgres_fdw
  • pg_stat_statements
  • pgrowlocks
  • citext
  • btree_gin
  • ltree
  • btree_gist
  • pgcrypto
  • chkpass
  • cube
  • pg_trgm
  • dict_int
  • tablefunc
  • fuzzystrmatch
  • tsearch2 (no longer supported in pg 10)
  • unaccent
  • intarray
  • isn
  • intagg
  • earthdistance
  • sslinfo
  • pg_prewarm
  • jsonbx (no longer supported in pg 10)
  • pg_hint_plan (no longer supported in pg 10)
  • "uuid-ossp"
  • plcoffee
  • plls
  • plv8
  • zhparser (no longer supported in pg 10)
  • pgrouting
  • postgis_tiger_geocoder