tencent cloud

腾讯云可观测平台

云数据库 MySQL

下载
聚焦模式
字号
最后更新时间: 2024-11-18 10:50:35
由客户云上购买和使用的资源实例与产品产生的监控事件包括:
事件中文名称
事件英文名称
事件类型
从属维度
有无恢复概念
事件描述
处理方法和建议
内存 OOM
OutOfMemory
异常事件
云数据库 MySQL 实例维度
有
数据库内存使用过载。
评估当前数据库内存规格是否满足业务需求,如果需要更大的内存建议升级 MySQL 的内存配置。
主从切换
Switch
异常事件
云数据库 MySQL 实例维度
有
主实例和从实例发生切换。
当物理机故障时可能会触发该事件,请确认实例状态是否正常。
只读实例剔除
RORemoval
异常事件
云数据库 MySQL 实例维度
有
只读实例故障或超过延迟阈值。
若只读组仅一个只读实例,只读实例被剔除后,请及时对读流量进行切换,避免因只读实例出现单点故障,建议为只读组至少购买两个只读实例。
服务器故障导致实例迁移
ServerfailureInstanceMigration
异常事件
云数据库 MySQL 实例维度
有
服务器故障发起的实例迁移。
迁移切换时间以维护时间窗为准,若需要更改切换时间,请及时调整,切换时间将以调整后的维护时间窗为准。
审计功能关闭
Auditclose
异常事件
云数据库 MySQL 实例维度
无
该事件已废弃,不再使用。
该事件已废弃,不再使用。
实例复制状态
InstRepStatus
异常事件
云数据库 MySQL 实例维度
有
RO 实例和主实例之间的主从同步是否正常,需配置 RO 实例。
受限于只读实例的规格或主实例存在大事务易导致该异常。可以适当增加只读实例配置或减少大事务。
数据库代理挂载节点剔除
ProxyNodeRemoval
异常事件
云数据库 MySQL 实例维度
有
满足保留最小只读节点数以及延迟剔除时间的只读节点,由于延迟过大、出现异常无法连接、I/O 线程、SQL 线程异常,将只读节点剔除。
若数据库代理仅有一个只读实例,只读实例被剔除后,避免因只读实例出现单点故障,建议为数据库代理至少配置两个只读实例。
数据库代理异常
ProxyNotAvailable
异常事件
云数据库 MySQL 实例维度
有
Proxy 代理节点出现故障,故障节点无法提供代理服务。
当数据库代理异常后,无法通过数据库代理 VIP 访问数据库实例,请确保打开数据库代理故障转移能力。
实例只读(硬盘超限)
Outofstorage
异常事件
云数据库 MySQL 实例维度
有
数据库磁盘使用过载。
评估当前数据库磁盘规格是否满足业务需求,如果需要更大的磁盘空间建议扩容 MySQL 的磁盘容量。
计划内主备切换
PlannedSwitch
异常事件
云数据库 MySQL 实例维度
无
实例因人工操作(变配、升级、主动切换等)原因触发并完成主备任务切换。
实例因人工操作(变配、升级、主动切换等)原因触发并完成主备任务切换,切换过程中会存在秒级连接闪断,请检查程序连接是否正常,建议程序设置自动重连机制以避免切换影响。
内存使用率过高
MemoryUsedHigh
异常事件
云数据库 MySQL 实例维度
有
内存使用率过高。
监测到该实例当前内存使用率过高,存在运行风险。为了降低数据库实例的运行风险,可以扩容数据库实例内存规格或通过 数据库智能管家 DBbrian 进行运行分析。
服务器存在隐患导致实例迁移
BackendInstanceMigration
异常事件
云数据库 MySQL 实例维度
有
因服务器存在运行隐患发起的实例迁移。
监测到该实例运行环境存在硬件隐患,为了降低数据库实例故障发生概率,目前已发起实例迁移,迁移过程中不影响业务的正常使用。数据库实例将在您设定的维护时间窗进行切换,届时会有一次秒级闪断,请确保业务具备重连机制。如需更改切换时间,请及时调整维护时间窗,切换时间将以调整后的维护时间窗为准。
CPU 性能扩容
CPUExpansion
异常事件
云数据库 MySQL 实例维度
无
根据设定阈值触发 CPU 扩容。
实例因 CPU 使用率达到设定阈值触发 CPU 性能扩容,扩容行为不会对实例运行产生影响。
CPU 性能扩容失败
CPUExpansionFailed
异常事件
云数据库 MySQL 实例维度
无
根据设定阈值触发 CPU 扩容失败。
实例因为本地剩余资源不满足 CPU 扩容需求,最终扩容失败。稍后会重新发起。
CPU 性能回缩
CPUContraction
异常事件
云数据库 MySQL 实例维度
无
根据设定阈值触发 CPU回缩。
实例因 CPU 使用率达到设定阈值触发 CPU 性能回缩,回缩后需要观察当前配置是否满足业务运行需要。
异常故障导致实例计算资源重建
Instance rebuilt caused by exception
异常事件
云数据库 MySQL 实例维度
无
数据库异常导致实例计算资源重建。
当前数据库因运行故障导致实例资源重建。请后续评估数据库当前规格是否满足业务需求,如果需要更高的规格建议升级 MySQL 的配置。
磁盘使用超限锁定
OverusedReadonlySet
异常事件
云数据库 MySQL 实例维度
无
因磁盘空间使用超限,数据库实例被设置为锁定状态,锁定后无法继续进行数据写入或提供服务。
1. 可以将本地 binlog 保留时间降低,释放部分空间。
2. 尝试清理不需要的数据库表,以释放空间。
3. 数据库实例扩容磁盘上限。
实例解除锁定
OverusedReadWriteSet
异常事件
云数据库 MySQL 实例维度
无
数据库实例解除锁定状态,提供完整的数据库服务。
1. 可以将本地 binlog 保留时间降低,释放部分空间
2. 尝试清理不需要的数据库表,以释放空间
3. 数据库实例扩容磁盘上限
实例将被锁定
OverusedPreReadonly
异常事件
云数据库 MySQL 实例维度
无
因磁盘空间使用超限,数据库实例即将被设置为锁定状态,锁定后无法继续进行数据写入或提供服务。
1. 可以将本地 binlog 保留时间降低,释放部分空间
2. 尝试清理不需要的数据库表,以释放空间
3. 数据库实例扩容磁盘上限
数据库审计低风险
AuditLowRisk
异常事件
云数据库 MySQL 实例维度
无
审计日志命中了低风险规则。
请前往 控制台 查看详细的告警日志信息,并根据业务情况进行处理。告警原因是审计日志命中了低风险规则。
数据库审计中风险
AuditMediumRisk
异常事件
云数据库 MySQL 实例维度
无
审计日志命中了中风险规则。
请前往 控制台 查看详细的告警日志信息,并根据业务情况进行处理。告警原因是审计日志命中了中风险规则。
数据库审计高风险
数据库审计高风险
异常事件
云数据库 MySQL 实例维度
无
审计日志命中了高风险规则。
请前往 控制台 查看详细的告警日志信息,并根据业务情况进行处理。告警原因是审计日志命中了高风险规则。
控制台操作事件(基于操作审计投递)
Console operations (CloudAudit)
异常事件
实例维度
无
实例增删、变配等操作事件。
人工排查。
云 API 操作事件(基于操作审计投递)
Cloud API actions (CloudAudit)
异常事件
实例维度
无
实例增删、变配等操作事件。
人工排查。
小程序操作事件(基于操作审计投递)
Mini program operations (CloudAudit)
异常事件
实例维度
无
实例增删、变配等操作事件。
人工排查。
主节点服务拨测异常(原主节点服务故障)
MasterHealthCheckError
异常事件
云数据库 MySQL 实例维度
无
主实例可能因高负载、连接数满、运行异常、网络波动等情况导致无法判断当前主实例节点服务状态为存活。
可适当增加节点配置来降低风险发生的概率。
1. 如您收到 MasterHealthCheckRecovery 事件,则代表主节点恢复,HA 切换回滚,并未实际发生 HA。
2. 如您收到 Switch 和 SlaveHealthCheckRecovery,则代表发生 HA 并成功恢复。
3. 如您收到 Switch,但没收到 SlaveHealthCheckRecovery,则代表发生 HA 且原 Master 实例被重建。
主节点服务拨测异常恢复(原主节点服务故障恢复)
MasterHealthCheckRecovery
恢复事件
云数据库 MySQL 实例维度
无
数据库主节点出现服务异常后恢复。
数据库主节点服务异常(MasterHealthCheckError)已恢复,可正常运行。
备节点服务拨测异常(原备节点服务故障)
SlaveHealthCheckError
异常事件
云数据库 MySQL 实例维度
无
备实例可能因高负载、连接数满、运行异常、网络波动等情况导致无法判断当前备实例节点服务状态为存活。
可适当增加节点配置或只读节点数量来降低风险发生的概率。
1. 如您收到 SlaveHealthCheckRecovery,说明备节点已恢复。
2. 如您未收到 SlaveHealthCheckRecovery,则说明备节点拨测已超时重建。
备节点服务拨测异常恢复(原备节点服务故障恢复)
SlaveHealthCheckRecovery
恢复事件
云数据库 MySQL 实例维度
无
1. 数据库备节点出现服务异常后恢复。
2. 原主节点异常,主备切换后,原异常主节点恢复为备节点。
1. 数据库备节点服务异常(SlaveHealthCheckError)已恢复,可正常运行。
2. 数据库原主节点服务异常(MasterHealthCheckError)已恢复,可正常运行。
客户云上购买和使用云数据库 MySQL 集群版实例产生的监控事件如下:
事件中文名称
事件英文名称
事件类型
从属维度
有无恢复概念
事件描述
处理方法和建议
实例重启
Restart
异常事件
云数据库 MySQL 实例维度
有
1. 实例因人工操作(重启、参数变更等)原因触发实例重启。
2. 流程中存在重启过程触发事件告警。
1. 实例因人工操作(重启、参数变更等)原因触发实例重启。重启过程中会存在秒级连接闪断,请检查程序连接是否正常,建议程序设置自动重连机制以避免切换影响。该事件存在恢复状态,请留意后续事件推送。
2. 流程中存在重启过程触发该事件告警,该类告警可结合其他事件一同观测。
内存 OOM
OutOfMemory
异常事件
云数据库 MySQL 节点维度
有
数据库内存使用过载。
评估当前数据库内存规格是否满足业务需求,如果需要更大的内存建议升级 MySQL 的内存配置。该事件存在恢复状态,请留意后续事件推送。
主从切换
Switch
异常事件
云数据库 MySQL 实例维度
有
主实例和从实例发生切换。
当物理机故障时可能会触发该事件,请确认实例状态是否正常。该事件存在恢复状态,请留意后续事件推送。
节点服务异常导致节点重建
ServerFailureNodeMigration
异常事件
云数据库 MySQL 节点维度
有
集群版节点故障发起节点重建。
迁移切换时间以维护时间窗为准,若需要更改切换时间,请及时调整,切换时间将以调整后的维护时间窗为准。该事件存在恢复状态,请留意后续事件推送。
节点复制状态
RoNodeRepStatus
异常事件
云数据库 MySQL 节点维度
有
集群版 RO 节点和主实例之间的主从同步是否正常,需配置 RO 节点。
受限于只读节点的规格或主实例存在大事务易导致该异常,可以适当增加只读节点配置或减少大事务。该事件存在恢复状态,请留意后续事件推送。
磁盘使用超限锁定
OverusedReadonlySet
异常事件
云数据库 MySQL 实例维度
无
因磁盘空间使用超限,数据库实例被设置为锁定状态,锁定后无法继续进行数据写入或提供服务。
1. 可以将本地 binlog 保留时间降低,释放部分空间。
2. 尝试清理不需要的数据库表,以释放空间。
3. 数据库实例扩容磁盘上限。
实例解除锁定
OverusedReadWriteSet
异常事件
云数据库 MySQL 实例维度
无
数据库实例解除锁定状态,提供完整的数据库服务。
数据库实例锁定状态(OverusedReadonlySet)已解除。
计划内主备切换
PlannedSwitch
异常事件
云数据库 MySQL 实例维度
无
实例因人工操作(变配、升级、主动切换等)原因触发并完成主备任务切换。
实例因人工操作(变配、升级、主动切换等)原因触发并完成主备任务切换,切换过程中会存在秒级连接闪断,请检查程序连接是否正常,建议程序设置自动重连机制以避免切换影响。
读写节点服务检测异常
RWNodeException
异常事件
云数据库 MySQL 节点维度
无
读写节点可能因高负载、连接数满、运行异常等情况导致无法判断当前读写节点状态为存活。
可适当增加节点配置来降低风险发生的概率,搭配使用 RWNodeExceptionRecovery 查看服务是否已恢复,搭配使用 Switch 查看本次异常是否触发切换。
读写节点服务异常恢复
RWNodeExceptionRecovery
异常事件
云数据库 MySQL 节点维度
无
读写节点运行状态已恢复。
读写节点运行状态(RWNodeException)已恢复。
只读节点服务检测异常
RONodeException
异常事件
云数据库 MySQL 节点维度
无
只读节点可能因高负载、连接数满、运行异常等情况导致无法判断当前只读节点状态为存活。
可适当增加节点配置或只读节点数量来降低风险发生的概率,搭配使用 RONodeExceptionRecovery 查看服务是否已恢复,搭配使用 Switch 查看本次异常是否触发切换。
只读节点服务异常恢复
RONodeExceptionRecovery
异常事件
云数据库 MySQL 节点维度
无
只读节点运行状态已恢复。
只读节点运行状态(RONodeException)已恢复。

帮助和支持

本页内容是否解决了您的问题?

填写满意度调查问卷,共创更好文档体验。

文档反馈