本文では、コンソールを介してTDSQL-C for MySQLクラスタに作成できるアカウントタイプ、およびアカウントの作成、読み書き属性の変更の操作方法と関連説明についてご案内します。
アカウントタイプ
以下の表から、TDSQL-C for MySQLがサポートするアカウントタイプを確認できます。
説明:
本文の説明では、プライマリインスタンスは読み書きインスタンスを指します。
|
ルートアカウント | 読み書きアカウント | 読み書きアカウント(自動) | クラスタ作成後、このアカウントはデフォルトで生成され、かつ一意です。クラスタ作成後にrootアカウントを追加することはできません。 このアカウントの読み書き属性はデフォルトで「読み書きアカウント(自動)」となり、変更はサポートされていません。 |
非rootアカウント | 読み書きアカウント | 読み書きアカウント(自動) | クラスタ作成後、このタイプのアカウントを個別に再作成することができます。 読み書き属性の変更をサポートしています。 |
|
| 読み書きアカウント(プライマリインスタンスのみアクセス) | クラスタ作成後、このタイプのアカウントを個別に再作成することができます。 読み書き属性の変更をサポートしています。 |
| 読み取り専用アカウント | 読み取り専用アカウント(読み取り専用障害時エラー) | クラスタ作成後、このタイプのアカウントを個別に再作成することができます。 読み書き属性の変更をサポートしています。 |
|
| 読み取り専用アカウント(読み取り専用障害時はプライマリインスタンスから読み取り) | クラスタ作成後、このタイプのアカウントを個別に再作成することができます。 読み書き属性の変更をサポートしています。 |
読み書き属性の説明
TDSQL-C for MySQLのアカウント作成機能で、読み書き属性を設定する機能が新たにサポートされました。注意すべき点として、ここでの読み書き属性は、従来の意味でMySQLに直接接続して作成され、ユーザーのテーブルデータに対する操作権限(SELECTやINSERTなど)を制御するためのアカウント権限ではなく、データベースプロキシ層に固有の接続リクエスト分散制御属性です。
読み書き属性自体は、お客様のアカウントが実際にMySQLに接続する際に持つ読み取りまたは書き込み権限とは無関係です。その目的は、お客様のリクエストを読み取り専用インスタンスまたは読み書きインスタンスに正確に振り分けることです。データベースプロキシの接続アドレスを介してクラスタにアクセスするアカウントに読み書き属性を設定すると、そのアカウントは対応するルーティング機能を持つようになります:ユーザーは1つのプロキシ接続アドレスと1つのアカウントを使用するだけで、プロキシアドレスを変更せず、業務コードを変更せずに、データベースプロキシがアカウントの読み書き属性に基づいて、受信したデータベースリクエストを指定されたインスタンス(読み書きインスタンスRWまたは読み取り専用インスタンスRO)に完全かつ均等に自動振り分けします。各タイプの説明は以下の通りです:
説明:
読み書きアカウント(プライマリインスタンスのみアクセス)、読み取り専用アカウント(読み取り専用障害時エラー)および読み取り専用アカウント(読み取り専用障害時プライマリインスタンス読み取り)は特殊アカウントです。
この属性では、お客様のアカウントの読み書きリクエスト分散能力は、データベースプロキシが有効かどうかによって決まります。データベースプロキシを有効にしていない場合は、このアカウントでMySQLに直接接続できます。データベースプロキシを有効にしている場合は、その読み書き分離機能により読み書きリクエストを自動的に区別し、書き込みリクエストを読み書きインスタンスに、読み取りリクエストを読み取り専用インスタンスに送信します。
読み書きアカウント(プライマリインスタンスのみアクセス)
この属性では、お客様のリクエストはデフォルトで読み書きインスタンスにのみルーティングされます。読み取り専用インスタンスにアクセスする必要がある場合は、HINTで指定できます。
この属性では、お客様のリクエストは読み取り専用インスタンスにのみルーティングされます。読み取り専用障害エラーとは、データベースプロキシアドレスを使用してデータベースに接続している際に、読み取り専用インスタンスで障害が発生した場合、読み取りリクエストが直接エラーとなり、読み書きインスタンスに転送されないことを意味します。
読み取り専用アカウント(読み取り専用障害時にプライマリインスタンスを読み取る)
この属性では、お客様のリクエストは読み取り専用インスタンスにのみルーティングされます。読み取り専用障害時読み取りプライマリインスタンスとは、データベースプロキシアドレスを使用してデータベースに接続している際に、読み取り専用インスタンスで障害が発生した場合、読み取りリクエストが読み書きインスタンスに転送されることを意味します。
注意事項
データベースプロキシのオン/オフと読み書き属性:データベースプロキシが有効になっていない場合、読み書き属性が「読み書きアカウント(自動)」のアカウントのみ作成でき、特殊アカウントは作成できません。特殊アカウントを作成する必要がある場合は、先にデータベースプロキシを有効にしてください。 データベースプロキシの無効化に関する説明:アカウントが特殊アカウントに設定されている場合、ユーザーがデータベースプロキシを無効にすると、システムは「非自動タイプのアカウントが有効になっています。データベースプロキシを無効にすると使用できなくなります」と表示します。データベースプロキシを無効化する場合、対応する特殊アカウントは読み書き属性の変更がサポートされず、データベースプロキシを再度有効にした後にのみ読み書き属性の変更がサポートされます。
読み取り専用分析エンジンを有効にすると、システムはデフォルトでデータベースに「txsqlPlugins_analytics_repl」という名前のアカウントを作成します。このアカウントは、読み取り専用分析エンジンが読み書きインスタンスからデータを取得するために使用されます。このアカウントを削除しないでください。
アカウントの作成
2. 上方でリージョンを選択し、実際のコンソールビューモードに基づいて対応する操作を行ってください。
左側のクラスタリストでターゲットクラスタをクリックすると、クラスタ管理ページに移動します。
左側のクラスタリストでターゲットクラスタを見つけ、クラスタIDまたは操作列の管理をクリックすると、クラスタ管理ページに移動します。
3. クラスタ管理ページで、アカウント管理ページを選択して、アカウント作成をクリックします。
4. アカウント作成ウィンドウで、以下の情報を設定し、確定をクリックします。
|
アカウント名 | データベースアカウント名は1~30文字で、アルファベット、数字、特殊文字で構成されます。アルファベットで始まり、アルファベットまたは数字で終わります。特殊文字は_です。 |
ホスト | 指定したホストアドレスからデータベースにアクセスします。IP形式をサポートし、%の入力もサポートします。複数のホストは区切り文字で区切ります。区切り文字は;,|改行文字およびスペースをサポートします。 示例1:%を入力すると、IP範囲制限を行わないことを示します。つまり、すべてのIPアドレスのクライアントがこのアカウントを使用してデータベースにアクセスできます。 説明: ホストに%を入力すると、アカウントのセキュリティリスク(悪意のある接続やブルートフォース攻撃など)が発生する恐れがあります。データベースへのアクセスには具体的なホストアドレスを指定することを推奨します。 示例2:10.5.10.%を入力すると、IP範囲が10.5.10.%内のクライアントがこのアカウントを使用してデータベースにアクセスできることを示します。 |
アカウントタイプ | アカウントタイプを選択します。 読み書きアカウント。 読み取り専用アカウント。 |
読み書きポリシー | アカウントタイプが読み書きアカウントの場合のみ、読み書きポリシーを設定する必要があります。ポリシーの説明については読み書き属性の説明を参照してください。 自動。 プライマリインスタンスのみにアクセスします。 |
障害転送ポリシー | アカウントタイプが読み取り専用アカウントの場合のみ、障害転送ポリシーを設定する必要があります。ポリシーの説明については読み書き属性の説明を参照してください。 読み取り専用障害エラー。 読み取り専用に障害が発生した場合、プライマリインスタンスから読み取ります。 |
パスワードを設定する | パスワードの長さは8~64文字で、大文字と小文字の英字、数字、記号~!@#$%^&*_-+=`|\\(){}[]:;'<>,.?/のうち任意の3種類を含む必要があります。 |
パスワードを確認する | アカウントのパスワードを再度入力し、2回のパスワードが一致するようにしてください。 |
接続数制限 | このアカウントの接続数を制限する値を入力します。設定可能範囲:1~10240。 この項目を入力しない場合、追加の制限は行われず、このアカウントは最大接続数10240の制限を受けます。 コア取引業務では、接続数を50~200に設定できます。具体的には実際の業務に応じて設定してください。 内部運用システムでは、接続数を20~100に設定できます。具体的には実際の業務に応じて設定してください。 管理者/個人では、接続数を2~10に設定できます。具体的には実際の業務に応じて設定してください。 |
備考 | アカウントに備考を追加します。最大255文字まで入力できます。 |
5. データベースアカウントの作成後、アカウントリストで管理できます(権限の変更、パスワードのリセット、読み書き属性の変更、アカウントのクローン、アカウントの削除など。対応するアカウントでサポートされる具体的な操作については、コンソールの表示に従ってください)。
アカウントの読み書き属性の変更
2. 上方でリージョンを選択し、実際のコンソールビューモードに基づいて対応する操作を行ってください。
左側のクラスタリストでターゲットクラスタをクリックすると、クラスタ管理ページに移動します。
左側のクラスタリストでターゲットクラスタを見つけ、クラスタIDまたは操作列の管理をクリックすると、クラスタ管理ページに移動します。
3. クラスタ管理ページで、アカウント管理ページを選択します。
4. アカウントリストでターゲットアカウントを見つけ、その操作列の詳細 > 読み書き属性の変更をクリックします。
5. ポップアップウィンドウで、必要に応じてアカウントの読み書き属性を設定し、確定をクリックします。
関連するAPI
|
| 本インターフェース(CreateAccounts)はユーザーアカウントを作成するために使用されます。 |