tencent cloud

TencentDB for MySQL

DocumentationTencentDB for MySQLFAQsPerformance Space MemoryHow to Determine Whether Storage Space Is Overused

How to Determine Whether Storage Space Is Overused

Download
Focus Mode
Font Size
Last updated: 2026-09-03 17:03:32
AI-Translated & Reviewed
When a TencentDB for MySQL instance runs out of storage space (disk) due to excessive data, the system automatically locks the instance to prevent partition failures on the host (the instance status becomes "Locked"). After the instance is locked, write operations cannot be performed on it. This document describes how to determine whether the storage space of an instance is overused.
Note:
The terms "storage space overuse", "storage overuse", "disk space overuse", and "disk overuse" described in this product document have the same meaning.

Causes of Storage Space Overuse

Data file usage is too high: data files occupy a large amount of disk space.
How to determine: The data file size of a local disk instance exceeds the purchased storage space.
You can monitor and determine whether the storage space of an instance is overused in the console under Instance Details > Disk Usage.

Locking Rules for Storage Space Overuse

Local disk instances use a storage-compute integrated architecture, where disk space is bound to the physical host and capacity has a clear upper limit. After this update, when the data file size of a local disk instance exceeds the purchased disk space (that is, disk overuse), the system will manage the instance in two phases: Pre-lock and Lock.
Control Phase
Trigger Timing
Instance State
Notification Method
Pre-lock
The data file size exceeds the purchased disk space.
Readable and writable
Trigger an "Instance to Be Pre-locked" event alarm.
Locked
The instance does not return to the non-overuse state within 24 hours after pre-locking.
Only read operations are allowed, and write operations will be rejected.
Trigger a "Disk Usage Overlimit Lock" event alarm.

Monitoring Metric Updates

The latest storage space metrics for local disk instances are as follows:
Metric Value
Definition
Capacity
User-used storage space (disk) size
CapacityRate
(User-used storage space (disk) size / Purchased space) * 100%
Purpose: Provided to users as a metric for determining whether storage space is billed for overuse
RealCapacity
Total storage space for data files
RealCapacityRate
(Instance data file storage space (disk) size / Purchased space) * 100%
Purpose: Provided to users as a metric for determining storage space overuse locking
LogFileCapacity
Total storage space for log files
LogCapacityBinlog
Storage space for binlog files
LogCapacityRedolog
Storage space for redolog files
LogCapacityUndolog
Storage space for undolog files
LogCapacityRelaylog
Storage space for relaylog files
LogCapacitySlowlog
Storage space for slowlog files
LogCapacityErrorlog
Storage space for errorlog files
LogFileCapacityElse
Storage space for log files other than those listed above
LogFileCapacityRate
(Total log file storage space / Purchased space) * 100%
CapacityElse
Instance temporary files and other files
DiskTmpUsed
Temporary files generated by operations such as temporary tables and sorting
OtherFileCapacity
Other uncategorized files
RemainCapacity
Purchased space - Storage space usage
RemainCapacityRate
((Purchased space - Storage space usage) / Purchased space) * 100%
For instructions on how to configure monitoring metric alarms, see Alarm Policy.

Event alarm

TCOP has added corresponding event metrics for storage space overuse events. After you configure event alarms for the corresponding event metrics and the alarm conditions are met, you will receive event alarm notifications from the system. Based on these notifications, you can determine whether storage space is overused and the lock status of the instance.

Alarm Metrics for Storage Space Overuse Events

Event Alarm Name
Trigger Timing
Recommended Action
Instance to Be Pre-locked.
The data file size exceeds the purchased disk space.
The instance remains readable and writable. Scale out or clean up data as soon as possible to prevent the instance from entering the locked state after 24 hours.
OverusedReadonlySet
Failure to return to the non-overuse state within 24 hours after pre-locking
The instance is read-only. Scale out or clean up data immediately to restore read/write access.
Pre-lock Released
Data file returns to within the purchased disk space during the pre-locking period.
No processing is required.
OverusedReadWriteSet
Complete scale-out or data cleanup during the lock period.
Monitor the recovery of business writes.

Setting Event Alarms

For detailed instructions on setting event alarms, see How to Set an Alarm for Storage Overuse Lock Events.

Help and Support

Was this page helpful?

Help us improve! Rate your documentation experience in 5 mins.

Feedback