Control Phase | Trigger Timing | Instance State | Notification Method |
Pre-lock | The data file size exceeds the purchased disk space. | Readable and writable | Trigger an "Instance to Be Pre-locked" event alarm. |
Locked | The instance does not return to the non-overuse state within 24 hours after pre-locking. | Only read operations are allowed, and write operations will be rejected. | Trigger a "Disk Usage Overlimit Lock" event alarm. |
Metric Value | Definition |
Capacity | User-used storage space (disk) size |
CapacityRate | (User-used storage space (disk) size / Purchased space) * 100% Purpose: Provided to users as a metric for determining whether storage space is billed for overuse |
RealCapacity | Total storage space for data files |
RealCapacityRate | (Instance data file storage space (disk) size / Purchased space) * 100% Purpose: Provided to users as a metric for determining storage space overuse locking |
LogFileCapacity | Total storage space for log files |
LogCapacityBinlog | Storage space for binlog files |
LogCapacityRedolog | Storage space for redolog files |
LogCapacityUndolog | Storage space for undolog files |
LogCapacityRelaylog | Storage space for relaylog files |
LogCapacitySlowlog | Storage space for slowlog files |
LogCapacityErrorlog | Storage space for errorlog files |
LogFileCapacityElse | Storage space for log files other than those listed above |
LogFileCapacityRate | (Total log file storage space / Purchased space) * 100% |
CapacityElse | Instance temporary files and other files |
DiskTmpUsed | Temporary files generated by operations such as temporary tables and sorting |
OtherFileCapacity | Other uncategorized files |
RemainCapacity | Purchased space - Storage space usage |
RemainCapacityRate | ((Purchased space - Storage space usage) / Purchased space) * 100% |
Event Alarm Name | Trigger Timing | Recommended Action |
Instance to Be Pre-locked. | The data file size exceeds the purchased disk space. | The instance remains readable and writable. Scale out or clean up data as soon as possible to prevent the instance from entering the locked state after 24 hours. |
OverusedReadonlySet | Failure to return to the non-overuse state within 24 hours after pre-locking | The instance is read-only. Scale out or clean up data immediately to restore read/write access. |
Pre-lock Released | Data file returns to within the purchased disk space during the pre-locking period. | No processing is required. |
OverusedReadWriteSet | Complete scale-out or data cleanup during the lock period. | Monitor the recovery of business writes. |
Was this page helpful?
You can also Contact sales or Submit a Ticket for help.
Help us improve! Rate your documentation experience in 5 mins.
Feedback