tencent cloud

TencentDB for MySQL

DocumentationTencentDB for MySQLTroubleshootingBackup and RestorationBackup Failure Caused by DDL Operations During Backup

Backup Failure Caused by DDL Operations During Backup

Download
Focus Mode
Font Size
Last updated: 2026-09-15 14:40:34
AI-Translated

Scenario Description

The TencentDB for MySQL instance failed to be backed up for two consecutive days, and DDL operations occurred within the backup time window.

Cause of the Issue

Full backups in TencentDB for MySQL are implemented based on xtrabackup. Because xtrabackup needs to obtain metadata locks during full backups to ensure data consistency, metadata lock conflicts exist between backup operations and DDL operations. When concurrent DDL operations occur within the backup time window, the backup process blocks while waiting for metadata locks until it times out and fails.
You can run the show processlist command to check whether DDL operations exist on the business side within the backup time window, and then adjust the backup policy accordingly or avoid executing DDL statements during this period.

Problem-solving Ideas

1. After stopping the relevant DDL operations, retry the manual backup.
2. It is recommended that subsequent DDL business change operations avoid the backup time window as much as possible.

Operation Steps

1. Stop the DDL operations that are being executed within the backup time window.
2. Log in to the TencentDB for MySQL console, go to the instance list, click an Instance ID to go to the management page, and choose Backup and Restoration > Manual Backup.

Help and Support

Was this page helpful?

Help us improve! Rate your documentation experience in 5 mins.

Feedback