tencent cloud

TencentDB for MySQL

Reasons for Backup Failures

Download
Focus Mode
Font Size
Last updated: 2026-09-15 14:45:55
AI-Translated
This document summarizes the possible causes of backup failures for TencentDB for MySQL instances. You can learn more from the following descriptions and guide documents.

Summary of Backup Failure Reasons

Scenario
Scenario Description
Documentation Link
Backup failure caused by the number of tables in a single instance exceeding 300,000.
If the number of tables in a single instance exceeds 300,000, it may cause backup failures, as well as impact database monitoring. It is recommended to reasonably standardize and control the number of tables per single instance to not exceed 300,000.
-
Backup failure caused by DDL operations during the backup.
The TencentDB for MySQL instance failed to back up for two consecutive days, and DDL operations were performed during the backup time window.
Automatic incremental backup failure caused by full disk space.
Automatic incremental backup was not performed for the database.
Replication interruption caused by the unique_checks parameter.
During the use of TencentDB for MySQL, replication interruption occurs on the standby instance or read-only instance.
Backup failure caused by secondary database exception resulting from foreign_key_checks.
After a routine change, the TencentDB for MySQL instance was restarted. The database instance started normally after the restart, but the following exceptions occurred:
When 'table' is accessed, an error is received from the client or application side: table 'parent' doesn't exist;.
The primary database appears normal, but the secondary database fails to load the table, causing the replication thread to disconnect abnormally (the Slave SQL thread reports an error).
A scheduled backup task fails, and the backup tool reports that the table does not exist when it executes SHOW TABLES, FLUSH TABLES, or exports the table.
The error log contains information indicating that InnoDB failed to load foreign key relationships during the open table phase.


Help and Support

Was this page helpful?

Help us improve! Rate your documentation experience in 5 mins.

Feedback